Mong các bác giúp em gấp vấn đề với SH404SEF !

Thảo luận các vấn đề vể cài đặt và sử dụng Joomla! và các thành phần mở rộng của Joomla!
Nội quy chuyên mục
Thành viên đăng quảng cáo trong chuyên mục này sẽ bị xóa toàn bộ bài viết và cấm vĩnh viễn tham gia Diễn đàn.

* Xem qui định đăng bài viết tại đây: Nội quy đăng bài viết
david10
Thành viên
Thành viên
Bài viết: 36
Ngày tham gia: 10/10/2011 - 09:04
Liên hệ:

Re: Mong các bác giúp em gấp vấn đề với SH404SEF !

Gửi bài gửi bởi david10 » 05/11/2011 - 09:49

Bác ơi sau khi sửa như trên thì nảy sinh 1 vấn đề nữa là khi chọn nhà sản xuất Levis thì link sẽ ra thế này :

Vui lòng đăng ký thành viên và đăng nhập để xem nội dung này.

Sau đó em click vào nhà sản xuất Nike thì link sẽ là thế này :

Vui lòng đăng ký thành viên và đăng nhập để xem nội dung này.?manufacturer_id=10

và kết quả sẽ vẫn là nhà sản xuất Levis. còn muốn tới nhà sản xuất Nike thì link phải thế này:
Vui lòng đăng ký thành viên và đăng nhập để xem nội dung này.&manufacturer_id=10

Tức là chỉ bị trục trặc ở mỗi dấu hỏi ở manufacturer_id đầu tiên thôi, còn lại phải dấu & sau đó dùng được và phải dùng dấu & mới hiển thị tiếp được !

Bác có cao kiến gì giúp em k ạ?

em nghĩ ở đoạn code này:
$currenturl = JURI::getInstance()->toString().'&manufacturer_id=';
Có cách nào để thay link manufacturer_id thành tên nhà sản xuất k ạ?

Cảm ơn bác nhiều!

Hình đại diện của thành viên
TruongLe
Thành viên
Thành viên
Bài viết: 1684
Ngày tham gia: 14/09/2010 - 20:20

Re: Mong các bác giúp em gấp vấn đề với SH404SEF !

Gửi bài gửi bởi TruongLe » 05/11/2011 - 13:11

sh404SEF phiên bản cũ tương thích không tốt với VirtueMart lắm, chỉ dùng được với các chức năng (link) đơn giản thôi.

Nếu bạn có thể mua được phiên bản sh404SEF mới (có bản quyền) thì sẽ tương thích tốt hơn với VirtueMart.

:)
* Hãy sử dụng công cụ tìm kiếm của Diễn đàn trước khi đặt câu hỏi.
* Hãy đặt tên cho Chủ đề diễn tả đúng với nội dung để thuận tiện khi tìm kiếm.
* Hãy chia sẻ kiến thức của bạn vì không chỉ giúp được mọi người mà còn giúp mình ghi nhớ những điều đã biết!

manhtrung321
Thành viên
Thành viên
Bài viết: 171
Ngày tham gia: 13/02/2011 - 15:18

Re: Mong các bác giúp em gấp vấn đề với SH404SEF !

Gửi bài gửi bởi manhtrung321 » 05/11/2011 - 23:43

Phiên bản Sh404 cũ hay bị thế lắm bác ơi
Mình đang dùng bị hoài phát chán nè

david10
Thành viên
Thành viên
Bài viết: 36
Ngày tham gia: 10/10/2011 - 09:04
Liên hệ:

Re: Mong các bác giúp em gấp vấn đề với SH404SEF !

Gửi bài gửi bởi david10 » 06/11/2011 - 07:16

Em đang dùng phiên bản mới nhất rồi bác ạ, được cung cấp bởi diễn đàn rebitz

Đăng trả lời
  • Các chủ đề liên quan
    Trả lời
    Xem
    Bài viết mới nhất

Quay về

Quảng cáo trên trang Web BuaXua.VN