Bị lỗi Parse error: syntax error, unexpected $end in...

Thảo luận các vấn đề vể cài đặt và sử dụng Joomla! và các thành phần mở rộng của Joomla!
Nội quy chuyên mục
Thành viên đăng quảng cáo trong chuyên mục này sẽ bị xóa toàn bộ bài viết và cấm vĩnh viễn tham gia Diễn đàn.

* Xem qui định đăng bài viết tại đây: Nội quy đăng bài viết
minhanh
Thành viên
Thành viên
Bài viết: 10
Ngày tham gia: 01/11/2011 - 21:33

Bị lỗi Parse error: syntax error, unexpected $end in...

Gửi bài gửi bởi minhanh » 03/11/2011 - 08:12

Mình cài template jv lago phiên bản 1.5.x, giải nén bản quickstart ra và cài đặt xong vào trang Administrator thì ok, còn vào trang chủ xem giao diện thì bị lỗi như thế này:

Parse error: syntax error, unexpected $end in C:\wamp\www\TINRAOVAT\modules\mod_jv_sobi2tools\tmpl\vertical_effect.php on line 63

Bạn nào giúp mình sửa lỗi hoặc cho mình link để tải về mà không bi lỗi nhé.

Mình post code của PHP cho các bạn xem dùm nó sai chỗ nào nhé, cám ơn các bạn nhiều.

Mã: Chọn tất cả

<?php 
JHTML::_('behavior.mootools');
$document = &JFactory::getDocument();
$css = JURI::base().'modules/mod_jv_sobi2tools/assets/css/vertical.css';
$document->addStyleSheet($css);
JHTML::_('stylesheet','jvslidesmooth_css.php?id='.$module->id.'&width='.$slide_width.'&height='.$slide_height,'modules/mod_jv_sobi2tools/assets/css/');
JHTML::_('script','jd.gallery.js','modules/mod_jv_sobi2tools/assets/js/');
JHTML::_('script','jd.gallery.transitions.js','modules/mod_jv_sobi2tools/assets/js/');
?>
<script type="text/javascript">
function startSlideshow<?php echo $module->id; ?>() {
    var mySlideshow<?php echo $module->id; ?> = new gallery($('mySlideshow<?php echo $module->id; ?>'), {       
        defaultTransition:'<?php echo $params->get('vertical_style'); ?>',
        timed:true,       
        baseClass: 'jdSlideshow',              
        embedLinks:false,        
        showCarousel: false,       
        showInfopane:true,               
        slideBarItem:'<?php echo $slideBarItem; ?>',	
        fadeDuration:<?php echo $params->get('duration',500); ?>,
        showArrows:false,
        delay:'<?php echo $slideDelay; ?>'     
    });
}
window.addEvent('domready',startSlideshow<?php echo $module->id; ?>);
</script>
<div id="<?php echo $divSobi2; ?>" class="jv_sobi2_slideshow_wrap">
<div class="jv-maskslide" style=" <?php  echo $css_width; ?>;<?php echo $css_height; ?>">
<div id="slide_wrapper<?php echo $moduleId; ?>">
<div id="slide_outer<?php echo $moduleId; ?>" class="slide_outer">
    <div id="mySlideshow<?php echo $module->id; ?>">
    <?php foreach($aryItem as $item) { 
        $catId = modJvSobi2ToolHelper::getCatIdByItemId($item->itemid);      
        $link = JRoute::_("index.php?option=com_sobi2&sobi2Task=sobi2Details&catid={$catId}&sobi2Id={$item->itemid}&Itemid={$itemIdSobi2}");
    ?>
    <div class="imageElement">
        <h3><a class="smooth_link" href="<?php echo $link; ?>"><?php echo $item->title; ?></a></h3>
        <p><?php echo modJvSobi2ToolHelper::getWord($params,$item->descript); ?></p>       
        <img src="<?php echo JURI::base().'images/com_sobi2/clients/'.$item->image; ?>" class="full" alt="<?php echo $item->title; ?>" />
        <img src="<?php echo JURI::base().'images/com_sobi2/clients/'.$item->image; ?>" class="thumbnail" width="100" height="100" alt="<?php echo $item->title; ?>" />
    </div>
    <?php } ?>
    </div>    
    
</div>
</div>
</div>
<div id="jv_pagislide<?php echo $moduleId; ?>" class="jv-pagislide" style="<?php echo $css_height; ?>;<?php echo $css_slidebar_width; ?>">
<?php foreach($aryItem as $item) { 
    $catId = modJvSobi2ToolHelper::getCatIdByItemId($item->itemid);      
    $link = JRoute::_("index.php?option=com_sobi2&sobi2Task=sobi2Details&catid={$catId}&sobi2Id={$item->itemid}&Itemid={$itemIdSobi2}");
  ?>
    <div class="slideitem" style="<?php echo $css_item_heigth; ?>">
       <?php if($item->image !=''){ ?>
        <img width="<?php echo $image_width; ?>" height="<?php echo $image_height; ?>" border="0" alt="" src ="<?php echo JURI::base().'images/com_sobi2/clients/'.$item->image; ?>" />
       <?php } ?> 
       <a class="slidetitle" href="<?php echo $link; ?>"><?php echo $item->title; ?></a>
       <?php if($item->price) { ?><span class="slideextra"><?php echo $item->price;?></span> <? } ?>
       <p class="slidedes"><?php echo modJvSobi2ToolHelper::getWord($params,$item->descript); ?></p>
    </div>
<?php } ?>
</div>
</div>

Hình đại diện của thành viên
TruongLe
Thành viên
Thành viên
Bài viết: 1684
Ngày tham gia: 14/09/2010 - 20:20

Re: Bị lỗi Parse error: syntax error, unexpected $end in...

Gửi bài gửi bởi TruongLe » 03/11/2011 - 10:14

Nếu trang web báo lỗi nhưng vẫn hiển thị đầy đủ thì hãy thử tắt thông báo lỗi Trong Admin của Joomla!, vào Global Configuration -> Server -> Server Settings -> Error Reporting -> chọn None

:)
* Hãy sử dụng công cụ tìm kiếm của Diễn đàn trước khi đặt câu hỏi.
* Hãy đặt tên cho Chủ đề diễn tả đúng với nội dung để thuận tiện khi tìm kiếm.
* Hãy chia sẻ kiến thức của bạn vì không chỉ giúp được mọi người mà còn giúp mình ghi nhớ những điều đã biết!

minhanh
Thành viên
Thành viên
Bài viết: 10
Ngày tham gia: 01/11/2011 - 21:33

Re: Bị lỗi Parse error: syntax error, unexpected $end in...

Gửi bài gửi bởi minhanh » 03/11/2011 - 11:06

Thanks bạn nhiều lắm, nhưng vẫn không được bạn ơi, còn giải pháp nào hay hơn không vậy bạn.
Nó cũng vẫn bao lỗi như vậy:

Parse error: syntax error, unexpected $end in C:\wamp\www\TINRAOVAT\modules\mod_jv_sobi2tools\tmpl\vertical_effect.php on line 63

Hình đại diện của thành viên
TruongLe
Thành viên
Thành viên
Bài viết: 1684
Ngày tham gia: 14/09/2010 - 20:20

Re: Bị lỗi Parse error: syntax error, unexpected $end in...

Gửi bài gửi bởi TruongLe » 04/11/2011 - 09:33

Bạn hãy kiểm tra phiên bản PHP của Server và Joomla! đang sử dụng.

:)
* Hãy sử dụng công cụ tìm kiếm của Diễn đàn trước khi đặt câu hỏi.
* Hãy đặt tên cho Chủ đề diễn tả đúng với nội dung để thuận tiện khi tìm kiếm.
* Hãy chia sẻ kiến thức của bạn vì không chỉ giúp được mọi người mà còn giúp mình ghi nhớ những điều đã biết!

minhanh
Thành viên
Thành viên
Bài viết: 10
Ngày tham gia: 01/11/2011 - 21:33

Re: Bị lỗi Parse error: syntax error, unexpected $end in...

Gửi bài gửi bởi minhanh » 04/11/2011 - 14:16

Cám ơn bạn nhiều nhe, mình tiếp tục nghiên cứu ra lỗi này thôi.

Mình dân Kinh tế nên gà mờ quá!

Đăng trả lời
  • Các chủ đề liên quan
    Trả lời
    Xem
    Bài viết mới nhất

Quay về

Quảng cáo trên trang Web BuaXua.VN