Lỗi khi đưa thông tin từ diễn đàn SMF lên trang chủ

Thảo luận các vấn đề vể cài đặt và sử dụng Joomla! và các thành phần mở rộng của Joomla!
Nội quy chuyên mục
Thành viên đăng quảng cáo trong chuyên mục này sẽ bị xóa toàn bộ bài viết và cấm vĩnh viễn tham gia Diễn đàn.

* Xem qui định đăng bài viết tại đây: Nội quy đăng bài viết
Hình đại diện của thành viên
TruongLe
Thành viên
Thành viên
Bài viết: 1684
Ngày tham gia: 14/09/2010 - 20:20

Re: Lỗi khi đưa thông tin từ diễn đàn SMF lên trang chủ

Gửi bài gửi bởi TruongLe » 19/10/2010 - 14:50

quocbinhvip đã viết:Bác nào viết module này cho em hỏi chút. Module này để đưa thông tin từ smf 1.x lên joomla nhưng forum của em là smf 2.x nên dùng không được, bác nào cải tiến cho nó dùng được cả với smf 2.x với.
khi forum là smf 2.x mà dùng module đó thì nó báo lỗi

Mã: Chọn tất cả

Warning: require_once(..\smf\SSI.php) [function.require-once]: failed to open stream: No such file or directory in C:\xampp\htdocs\web\modules\mod_smf_toptopics\mod_smf_toptopics.php on line 28

Fatal error: require_once() [function.require]: Failed opening required '..\smf\SSI.php' (include_path='.;C:\xampp\php\PEAR') in C:\xampp\htdocs\web\modules\mod_smf_toptopics\mod_smf_toptopics.php on line 28
Mong được hồi âm sớm :geek:
Dùng thử Vui lòng đăng ký thành viên và đăng nhập để xem nội dung này.

:)
* Hãy sử dụng công cụ tìm kiếm của Diễn đàn trước khi đặt câu hỏi.
* Hãy đặt tên cho Chủ đề diễn tả đúng với nội dung để thuận tiện khi tìm kiếm.
* Hãy chia sẻ kiến thức của bạn vì không chỉ giúp được mọi người mà còn giúp mình ghi nhớ những điều đã biết!


Hình đại diện của thành viên
TruongLe
Thành viên
Thành viên
Bài viết: 1684
Ngày tham gia: 14/09/2010 - 20:20

Re: Lỗi khi đưa thông tin từ diễn đàn SMF lên trang chủ

Gửi bài gửi bởi TruongLe » 19/10/2010 - 18:55

Mới vừa kiểm tra lại các Module đưa thông tin từ diễn đàn SMF lên trang chủ Joomla! theo bài hướng dẫn tại: http://www.buaxua.vn/Thiet-ke-Web/Cach- ... oomla.html

Kết quả:
1/ Cài các Module này trên Joomla! 1.5.20 (Legacy mode) + SMF 1.1.11 => Tất cả 4 Module đều hiển thị tốt.

2/ Cài các Module này trên Joomla! 1.5.20 (Legacy mode) + SMF 2.0 RC3 => 3 Module (SMF Forum Online, SMF Forum Top Poster, SMF Forum top Topic) hiển thị tốt.

Riêng Module SMF Forum Latest Post/Topic chỉ hiển thị tốt khi chọn Topics/Posts: Topics, còn nếu chọn Posts thì sẽ bị lỗi:

Mã: Chọn tất cả

An Error Has Occurred!
Database error, given array of integer values is empty. (include_boards)
Cách sửa lỗi này như sau:

Mở file /modules/mod_smf_last/mod_smf_last.php

Tìm:

Mã: Chọn tất cả

   $out=ssi_recentPosts($smf_num, null,  'noecho'); flush(); 
} else {
   $out=ssi_recentTopics($smf_num, null,  'noecho'); flush();

Sửa lại thành:

Mã: Chọn tất cả

   $out=ssi_recentPosts($smf_num, null, null, 'array'); flush(); 
} else {
   $out=ssi_recentTopics($smf_num, null, null, 'array'); flush();
Như vậy là xong. Đối với các lỗi mà các bạn nêu trên thì trong quá trình test đều không thấy xuất hiện, vậy các bạn nên xem lại các thiết lập trong các Module, chú ý phần khai báo đường dẫn SMF path

Chúc các bạn thành công.

:)
* Hãy sử dụng công cụ tìm kiếm của Diễn đàn trước khi đặt câu hỏi.
* Hãy đặt tên cho Chủ đề diễn tả đúng với nội dung để thuận tiện khi tìm kiếm.
* Hãy chia sẻ kiến thức của bạn vì không chỉ giúp được mọi người mà còn giúp mình ghi nhớ những điều đã biết!

quocbinhvip
Thành viên
Thành viên
Bài viết: 17
Ngày tham gia: 17/09/2010 - 15:50
Liên hệ:

Re: Lỗi khi đưa thông tin từ diễn đàn SMF lên trang chủ

Gửi bài gửi bởi quocbinhvip » 19/10/2010 - 21:59

Mình dùng module SMF Forum top Topic trên Joomla! 1.5.20 (Legacy mode) + SMF 2.0 RC3
thì bị lỗi

Mã: Chọn tất cả

Connection Problems
Sorry, SMF was unable to connect to the database. This may be caused by the server being busy. Please try again later. 
:cry:
Bạn không có quyền cần thiết để xem các tệp đính kèm với bài đăng này.

Đăng trả lời
  • Các chủ đề liên quan
    Trả lời
    Xem
    Bài viết mới nhất

Quay về

Quảng cáo trên trang Web BuaXua.VN