Các Bác làm ơn cứu em gấp, lại lỗi nữa rồi

Thảo luận các vấn đề vể cài đặt và sử dụng Joomla! và các Extension của Joomla!
Nội quy chuyên mục
Thành viên đăng quảng cáo trong chuyên mục này sẽ bị xóa toàn bộ bài viết và cấm vĩnh viễn tham gia Diễn đàn.

* Xem qui định đăng bài viết tại đây: viewtopic.php?f=2&t=318247

Các Bác làm ơn cứu em gấp, lại lỗi nữa rồi

Gửi bàigửi bởi vuvuvu » 04/06/2011 - 16:23

Xin các bạn hướng dẫn xử lý lỗi sau.
Mình tạo sản phẩm có giá cụ thể, sau đó mình tạo giảm giá cho sản phẩm tuy nhiên trong Back-end thì hiển thị đúng nhưng khi xuất hiện trên web thì bi sai. Mình làm cùng một cách như vậy cho những sản phẩm khác thì có cái hiện đúng như trong back-end, có cai lại hiển thị sai. Mình không biết nguyên nhân tại sao, mong các bạn cứu giúp...gấp.Xin đa tạ
vuvuvu
Thành viên
Thành viên
 
Bài viết: 56
Ngày tham gia: 27/05/2011 - 16:07

Re: Các Bác làm ơn cứu em gấp, lại lỗi nữa rồi

Gửi bàigửi bởi vuvuvu » 04/06/2011 - 19:56

Xóa bỏ sản phẩm, thay đổi mã mới và hình ảnh sản phẩm mới rồi làm lại thì được. Mình đã chỉnh lại rồi nhưng chẳng biết lỗi từ đâu, website "lớn lên" chút nữa mà gặp lỗi này chắc chết. Các bạn có biết nguyên nhân thì chỉ giúp mình.Xin cảm ơn.
-------------------------
(1 ngày sau) Tiếp theo đó, web hiển thị hình ảnh, giá cả ok hết, mình đã kiểm tra hết các sản phẩm thì thấy hiển thị tốt không bị lỗi gì hết. Ngủ đêm sáng ngày dậy vẫn không sao, tự nhiên đến trưa mở web lên xem thử thì thấy một vài sản phẩm bị lỗi, kiểm tra thì thấy số lượng vẫn còn trong kho,hình ảnh vẫn còn vậy mà "nó" báo lỗi là "xin lỗi không tìm thấy sản phẩm". Potay luôn, đau cả cái đầu.
vuvuvu
Thành viên
Thành viên
 
Bài viết: 56
Ngày tham gia: 27/05/2011 - 16:07

Re: Các Bác làm ơn cứu em gấp, lại lỗi nữa rồi

Gửi bàigửi bởi TruongLe » 05/06/2011 - 17:25

:D

Các lỗi này thường xảy ra khi sửa lại từ các sản phẩm mẫu vì có thể chúng còn các thuộc tính khác ảnh hưởng đến giá.

Sau khi đã bỏ hoặc chỉnh sửa lại thuế, giảm giá, phí vận chuyển,... nếu sản phẩm vẫn còn bị lỗi giá thì bạn hãy xóa và làm lại cái mới.

Ngoài ra cũng lưu ý các bạn là hãy sử dụng các chức năng đơn giản trước, khi nào VM hoạt động ổn định rồi mới tìm hiểu thêm các chức năng khác để tránh khi bị lỗi thì không biết nguyên nhân do đâu.
* Hãy sử dụng công cụ tìm kiếm của Diễn đàn trước khi đặt câu hỏi.
* Hãy đặt tên cho Chủ đề diễn tả đúng với nội dung để thuận tiện khi tìm kiếm.
* Hãy chia sẻ kiến thức của bạn vì không chỉ giúp được mọi người mà còn giúp mình ghi nhớ những điều đã biết!
Hình đại diện của thành viên
TruongLe
Thành viên
Thành viên
 
Bài viết: 1684
Ngày tham gia: 14/09/2010 - 20:20

Re: Các Bác làm ơn cứu em gấp, lại lỗi nữa rồi

Gửi bàigửi bởi vuvuvu » 05/06/2011 - 20:14

Sau khi xóa sản phẩm và tạo lại sản phẩm thì giá mới (giá đã giảm), giá cũ (giá gốc) đã hiển thị đúng như yêu cầu.(mình phải đổi tên sản phẩm, đổi mã sản phẩm, đổi tên file ảnh) thì mới được, nếu không thì vẫn báo lỗi như thường. Vấn đề ở đây là sau khi mình xuất bản một sản phẩm mới, nó đã hiển thị đúng như yêu cầu nhưng sau đó ( 1 vài ngày sau) tự nhiên lại báo lỗi là "không tìm thấy sản phẩm này" mặc dù mình không hề chỉnh sửa hay thay đổi gì cả, kiểm tra trong kho thì sp vẫn còn.Nếu code sai (mình thực sự không rành về PHP) thì phải sai từ đầu, sao lại sai "giữa chừng"? web đang chạy tốt, bỗng nhiên vài ngày sau lại xãy ra lỗi.Đau đầu lắm rồi.
--------------
Toàn bộ template là mình làm mới lại theo ý mình, không dùng template mẫu. CSS do mình tự làm lại, không dùng cái nào của template mẫu cả.
vuvuvu
Thành viên
Thành viên
 
Bài viết: 56
Ngày tham gia: 27/05/2011 - 16:07


Quay về Joomla!

Đang trực tuyến

Đang xem chuyên mục này: Không có thành viên nào đang trực tuyến2 khách

Dịch vụ hỗ trợ thiết kế Web của BuaXua.vn Dịch vụ hỗ trợ thiết kế trang Web và hướng dẫn sử dụng Joomla!
Quảng cáo trên trang Web BuaXua.VN