Hướng dẫn cách làm - Hình ảnh minh họa - Phim hướng dẫn Lỗi khi đưa thông tin từ diễn đàn SMF lên trang chủ

Hôm nay, 03/12/2016 - 20:43

Múi giờ UTC + 7 Giờ



Nội quy chuyên mục


Thành viên đăng quảng cáo trong chuyên mục này sẽ bị xóa toàn bộ bài viết và cấm vĩnh viễn tham gia Diễn đàn.

* Xem qui định đăng bài viết tại đây: viewtopic.php?f=2&t=318247



Tạo chủ đề mới Gửi bài trả lời
Gửi bàiĐã gửi: 19/10/2010 - 14:50 
Hình đại diện của thành viên TruongLe

Ngoại tuyến

Thành viên

Thành viên

Ngày tham gia: 14/09/2010 - 20:20
Bài viết: 1655
Đã cảm ơn: 4 lần
Được cảm ơn: 638 lần
quocbinhvip đã viết:
Bác nào viết module này cho em hỏi chút. Module này để đưa thông tin từ smf 1.x lên joomla nhưng forum của em là smf 2.x nên dùng không được, bác nào cải tiến cho nó dùng được cả với smf 2.x với.
khi forum là smf 2.x mà dùng module đó thì nó báo lỗi
Mã:
Warning: require_once(..\smf\SSI.php) [function.require-once]: failed to open stream: No such file or directory in C:\xampp\htdocs\web\modules\mod_smf_toptopics\mod_smf_toptopics.php on line 28

Fatal error: require_once() [function.require]: Failed opening required '..\smf\SSI.php' (include_path='.;C:\xampp\php\PEAR') in C:\xampp\htdocs\web\modules\mod_smf_toptopics\mod_smf_toptopics.php on line 28

Mong được hồi âm sớm :geek:


Dùng thử Vui lòng đăng ký thành viên và đăng nhập để xem nội dung này.

:)

___________________________________________________
* Hãy sử dụng công cụ tìm kiếm của Diễn đàn trước khi đặt câu hỏi.
* Hãy đặt tên cho Chủ đề diễn tả đúng với nội dung để thuận tiện khi tìm kiếm.
* Hãy chia sẻ kiến thức của bạn vì không chỉ giúp được mọi người mà còn giúp mình ghi nhớ những điều đã biết!


Đầu trang
 Xem thông tin cá nhân  
 
Gửi bàiĐã gửi: 19/10/2010 - 16:12 
quocbinhvip

Ngoại tuyến

Thành viên

Thành viên

Ngày tham gia: 17/09/2010 - 15:50
Bài viết: 17
Đã cảm ơn: 3 lần
Được cảm ơn: 0 lần
Hic, bản này mất $ mà. có bản share free hok bác ới. chán quá ha. :?

___________________________________________________
Vui lòng đăng ký thành viên và đăng nhập để xem nội dung này.
Vui lòng đăng ký thành viên và đăng nhập để xem nội dung này.


Đầu trang
 Xem thông tin cá nhân  
 
Gửi bàiĐã gửi: 19/10/2010 - 18:55 
Hình đại diện của thành viên TruongLe

Ngoại tuyến

Thành viên

Thành viên

Ngày tham gia: 14/09/2010 - 20:20
Bài viết: 1655
Đã cảm ơn: 4 lần
Được cảm ơn: 638 lần
Mới vừa kiểm tra lại các Module đưa thông tin từ diễn đàn SMF lên trang chủ Joomla! theo bài hướng dẫn tại: Vui lòng đăng ký thành viên và đăng nhập để xem nội dung này. ... oomla.html

Kết quả:
1/ Cài các Module này trên Joomla! 1.5.20 (Legacy mode) + SMF 1.1.11 => Tất cả 4 Module đều hiển thị tốt.

2/ Cài các Module này trên Joomla! 1.5.20 (Legacy mode) + SMF 2.0 RC3 => 3 Module (SMF Forum Online, SMF Forum Top Poster, SMF Forum top Topic) hiển thị tốt.

Riêng Module SMF Forum Latest Post/Topic chỉ hiển thị tốt khi chọn Topics/Posts: Topics, còn nếu chọn Posts thì sẽ bị lỗi:
Mã:
An Error Has Occurred!
Database error, given array of integer values is empty. (include_boards)

Cách sửa lỗi này như sau:

Mở file /modules/mod_smf_last/mod_smf_last.php

Tìm:
Mã:
   $out=ssi_recentPosts($smf_num, null,  'noecho'); flush();
} else {
   $out=ssi_recentTopics($smf_num, null,  'noecho'); flush();

Sửa lại thành:
Mã:
   $out=ssi_recentPosts($smf_num, null, null, 'array'); flush();
} else {
   $out=ssi_recentTopics($smf_num, null, null, 'array'); flush();

Như vậy là xong. Đối với các lỗi mà các bạn nêu trên thì trong quá trình test đều không thấy xuất hiện, vậy các bạn nên xem lại các thiết lập trong các Module, chú ý phần khai báo đường dẫn SMF path

Chúc các bạn thành công.

:)

___________________________________________________
* Hãy sử dụng công cụ tìm kiếm của Diễn đàn trước khi đặt câu hỏi.
* Hãy đặt tên cho Chủ đề diễn tả đúng với nội dung để thuận tiện khi tìm kiếm.
* Hãy chia sẻ kiến thức của bạn vì không chỉ giúp được mọi người mà còn giúp mình ghi nhớ những điều đã biết!


Đầu trang
 Xem thông tin cá nhân  
 
Gửi bàiĐã gửi: 19/10/2010 - 21:59 
quocbinhvip

Ngoại tuyến

Thành viên

Thành viên

Ngày tham gia: 17/09/2010 - 15:50
Bài viết: 17
Đã cảm ơn: 3 lần
Được cảm ơn: 0 lần
Mình dùng module SMF Forum top Topic trên Joomla! 1.5.20 (Legacy mode) + SMF 2.0 RC3
thì bị lỗi
Mã:
Connection Problems
Sorry, SMF was unable to connect to the database. This may be caused by the server being busy. Please try again later.
:cry:


Vui lòng đăng ký thành viên và đăng nhập để xem nội dung ẩn trong bài này.

___________________________________________________
Vui lòng đăng ký thành viên và đăng nhập để xem nội dung này.
Vui lòng đăng ký thành viên và đăng nhập để xem nội dung này.


Đầu trang
 Xem thông tin cá nhân  
 
Hiển thị những bài viết cách đây:  Sắp xếp theo  
Tạo chủ đề mới Gửi bài trả lời
 Bạn đang xem trang 2 / 2 trang [ 9 bài viết ] [Chuyển đến trang] <<  1, 2

Các chủ đề liên quan


Múi giờ UTC + 7 Giờ


Bạn không thể tạo chủ đề mới trong chuyên mục này.
Bạn không thể trả lời bài viết trong chuyên mục này.
Bạn không thể sửa những bài viết của mình trong chuyên mục này.
Bạn không thể xoá những bài viết của mình trong chuyên mục này.
Bạn không thể gửi tập tin đính kèm trong chuyên mục này.

Chuyển đến:  
cron